AnsweredAssumed Answered

REST API

Question asked by pgemin on Mar 15, 2019
Latest reply on Mar 21, 2019 by jorisvandenboogaard

Hello Board Community,

 

I am trying to get data from my web-based ERP through REST APIs. I have created the data source connection using a Basic authentication mode with my credentials and a query with the parameters I used in Postman previously (witch worked). When I test the query, nothing is returned.

 

I looked at the BoardConnector log, and this is the error I get:

[15/03/2019 15:22:53] Impossible de charger le fichier ou l'assembly 'Newtonsoft.Json, Version=6.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed' ou une de ses dépendances. La définition trouvée du manifeste de l'assembly ne correspond pas à la référence de l'assembly. (Exception de HRESULT : 0x80131040)

 

Which translates into:

Could not load file or assembly 'Newtonsoft.Json, Version=6.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

 

I am using Board v.10.3.0.51220, (stand alone version, local client and server). I had 10.1.4.50129 version previously, which I uninstalled before installing the current one (installed as administrator).

  • I have checked that all .NET framework prerequisites have been installed, more specifically:
    • .NET framework 3.5 SP1 is active as a service.
    • .NET framework 4.0 and 4.5.1 are already installed (or so said the installer after I tried to install them again)
  • I have tried to connect to another API with no authentication (https://postman-echo.com/get ) which works fine in my browser and in Postman, but triggers the same error in Board.
  • I have tried to run Board client as administrator.
  • I have tried the same on another server (same Board version, Master license).
  • I saw that there are multiple versions of Newtonsoft.Json.dll on my system (4 are linked to Board, 3 of them are the same version for Client, Server and WebApi server, one is a different version in the WebApi Server\Snapshotter folder). I'm not sure if this information is relevant for my problem, though.
  • It seems the request doesn't reach my ERP (the log on their side shows connections from Postman, but none from Board)
  • I have tried to run the Board engine using the my Board Admin account instead of the local one

 

I'm out of ideas as to what to try next. Could someone lend me a hand? 

 

Thank you very much!

Paul

Outcomes