AnsweredAssumed Answered

BOARD 11.1 - Dataflow not working

Question asked by g.vialetto on Aug 21, 2019
Latest reply on Sep 10, 2019 by rjvkuppeveld

Dear all,

 

we are migrating a database from 10.3 to 11.1 but dataflow do not work. We start to check this dataflow


Net Sales (A) + Credit Notes (B) = Sales (C)

 

A and B has these entities: Day, Document No, Order, Item

 

C has these entities: Day, Customer, Order, Item

 

Document No and Customer are into a relationship. All relationship are checked and normalised. Consider that these dataflow "opens" new tuples of data because A has day1,item1,doc1 and B could have day1,item2,doc2.

 

We tried to perform these procedure:

 

Case 1 - NOT WORKING

 

A+B = C changing both calculus dominion and sparsity properties

 

 

 

Case 2 - NOT WORKING

 

We tried to define temporary cube A' and B' with same entities of C so the procedure became

 

A' = A

 

B' = B

 

C = A' + B'

 

Case 3 - NOT WORKING

 

We tried to open sparsity using

 

C = A

 

C = B

 

A + B = C

 

in these case we also experienced that BOARD performed only C = a, ignoring following steps.

 

Case 4 - NOT WORKING

 

We tried to open sparsity using

 

C = A

 

C = C + B

 

In all of the previous cases we tried also to select just a customer in a limited period of time (2 months) but the procedure does not work. We try also to define the dataflow into a dataview and perform a Learning Mode to create version of cube. As not working I mean:

 

- in some cases we experienced that BoardEngine and BoardWebApiEngine stopped automatically without user did it

 

- in some cases we had to stop it because BOARD was not responding

 

- in some cases BOARD performed the dataflow but number were strange

 

Checking on log I saw that it occurred Tuples.[Intersect]+ that probably is a new algorithm, I was not able to find any references about it.

Outcomes