AnsweredAssumed Answered

configure Board.Mailer.Service.exe.config

Question asked by rubicon on Nov 20, 2019
Latest reply on Dec 11, 2019 by aamirahsan

Hello Davide Genini,

I would like to comment this document: Board Mailer Service (version 3), but i don't see any comment features at the bottom at the document as i am used to see it, e.g. in How to setup Microsoft IIS with Board 10 Web Server (HTML 5).

  1. Is it possible to add the "add a comment" feature to the document Board Mailer Service?
  2. otherwise i ask here my question: I try to configure the Board Mailer service and i have the error named in the document:
    Windows error when attempting to start the Board Mailer Service: "1053 - The server did not       

    respond to the start or control request in a timely fashion."

I have configured the fles according to the document (i hope) and to the release notes for B11.1:

Broadcasting features installation

The broadcasting features (subscription, send to and broadcasting) require an additional service that execute the mailing function. The web API Engine installation (self-hosted) deploys a new service "BoardMailerService" that is used for the Broadcasting like functions. If the Web API Engine has been deployed under IIS, this new service is not automatically deployed on the instance. An additional set of CMD commands must be run on the server to deploy that service.

Below the commands for the "BoardMailerService" deploy:

 

"C:\Windows\Microsoft.NET\Framework\v4.0.30319\installutil.exe" "C:\inetpub\wwwroot\B10WEB\Bin\Board.Mailer.Service.exe"

sc config BoardMailerService start=auto

sc start BoardMailerService

 

Where "C:\inetpub\wwwroot\B10WEB" is the IIS path where the BOARD web application is hosted.

I have an on premises Server installation (Board 11.1 with IIS)

The files are configured as follow:

  • Broadcasting.config (in folder C:\inetpub\wwwroot\BOARDWEB11_1\App_Data\config)
<broadcastingConfiguration>
  <add key="internalSmtpAddress" value="smtp.xyz"/>
  <add key="internalSmtpPort" value="587"/>
  <add key="internalSmtpEnableSsl" value="on"/>
  <add key="mailerUsername" value="smtp-blabla"/>
  <add key="mailerPassword" value="Clear_Pwd_value"/>
  <add key="workingFolder" value="C:\...\BOARD\BoardApps\Board\z_Broadcasted_Files"/>
  <add key="mailerSender" value="board_broadcast@blabla.com"/>
  <add key="pollingMinutes" value="5"/>
</broadcastingConfiguration>
  • Board.Mailer.Service.exe.config (in folder C:\inetpub\wwwroot\BOARDWEB11_1\bin)
<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <appSettings configSource="App_Data\config\mailer.config"/>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5.2"/>
  </startup>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral"/>
        <bindingRedirect oldVersion="0.0.0.0-10.0.0.0" newVersion="10.0.0.0"/>
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
</configuration>
  • Mailer.config (in folder C:\inetpub\wwwroot\BOARDWEB11_1\App_Data\config)
<appSettings>
<add key="webUrl" value="http://my_Server_IP_address:80/" />
<add key="WatchPath" value="C:\inetpub\wwwroot\BOARDWEB11_1\App_Data\broadcasting"/>
<add key="LogFolder" value="C:\inetpub\wwwroot\BOARDWEB11_1\App_Data\broadcasting\log"/>
</appSettings>

 

 

Has anyone an idea of the reason why i got the error 1053 while trying to start the Board mailer service?

Outcomes