Culture-sensitivity with @datetime in Smart Import

Hi,

I have a bit of trouble with culture and the formula @datetime.

I have a cube that is populated 2 ways: either the user uses a smart import object to fill other cubes, and then the datetime information arrives into this timestamp cube using a formula.

Or, if the users don't want to input anything, they can click a button, and that automatically populates the cube with the datetime info.

My problem is that, in spite of both inputs being done by the same user (me 🙂 ), with the same culture settings, I am getting different formatting for the different inputs.

"No input" contract code is the procedure populated cell, "Test" code is the Smart Import populated cell.

I have seen a workaround for this in the thread:

However, this will only work with the procedure, and it will result in my timestamps being in the US format, while we would prefer the EU formatting. Is there any way to get the Smart Import formula to give us the EU formatted timestamp?

Thank you for any help!

Answers

  • Hi Krisztina, I know the culture settings of the specific user can affect the datetime formatting. Perhaps you can change the culture of your user in the Subscription Hub and check if it helps!

  • Hi Krisztina!

    If Gary's suggestion doesn't work, you might be coming across a known bug. Our development team is aware of instances where the @datetime format does not change correctly based on the of user's settings.

  • Krisztina Zappert
    Krisztina Zappert Active Partner
    Community Voices 5 Likes 5 Up Votes First Comment
    edited May 2023

    Hi @Gary Beardsley and @Zachary Turner , and thank you for your input!

    I have now tested changing the culture of the user from English (Sweden) to English (United States) and Hungary (Hungarian). Unfortunately, I still face the same issue.

    Since this seems to be a known issue, I will file a support case, so I can get updated when it is fixed.

    BR,

    Krisztina