Server Installer tries to install .NET Framework which is already installed


I'm trying to install Board 10.7 server on an airgapped server (so it can't connect to the internet during the install process to download .NET framework). We've used the offline installer for 4.8 .net framework, and after some mucking around we seem to have it installed (at least going on the the registry entries).

When I run the Board server installer, it still tries to download .NET framework, and given it can't reach the internet, the installer fails.

Has anyone else had issues getting the Board installer to recognise 4.8 .NET FW is already installed and has any ideas that will help with a server that can't go online?





  • Hi Mike,

    have you tried using the *.msi installation package?

    It is designed for offline-installation like yours.



  • Michael Manes
    Michael Manes Customer
    Third Anniversary First Comment
    edited September 15

    Hi Fabian,

    I haven't, thanks for the idea!

    I do have a BSResources.msi install file in the same folder (147,256KB) alongside the setup.exe - would that be the right one?



  • Federico Cazzalini
    Federico Cazzalini Employee
    Third Anniversary 25 Up Votes 10 Comments 25 Likes

    Dear Michael,

    I confirm: that behavior was a little bug of the 10.7 .exe installer - we fixed it with 10.8

    you can use the .msi (yes, it is the one you found in the same folder)

    please remember that Board 10 is really old and out of maintenance from 31-12-2022 - our suggestion is to upgrade to Summer23 (board 12.6)

    it's faster, more stable, many more features and so on! :)



  • Hi Federico,

    Thanks for confirming, I was able to successfully install directly from the .msi files.

    Yep, unfortunately we are a little behind the times but making progress - we have upgraded to 10.7 to start using web capsules, as the next step on our journey to 12.6